issue_comments

7 rows where user = 4312421 sorted by updated_at descending

View and edit SQL

Suggested facets: issue_url, created_at (date), updated_at (date)

user

  • stonebig · 7

author_association

id html_url issue_url node_id user created_at updated_at ▲ author_association body reactions issue
623623696 https://github.com/simonw/datasette/pull/725#issuecomment-623623696 https://api.github.com/repos/simonw/datasette/issues/725 MDEyOklzc3VlQ29tbWVudDYyMzYyMzY5Ng== stonebig 4312421 2020-05-04T18:16:54Z 2020-05-04T18:16:54Z NONE

thanks a lot, Simon

{
    "total_count": 0,
    "+1": 0,
    "-1": 0,
    "laugh": 0,
    "hooray": 0,
    "confused": 0,
    "heart": 0,
    "rocket": 0,
    "eyes": 0
}
Update aiofiles requirement from ~=0.4.0 to >=0.4,<0.6 598891570
619489720 https://github.com/simonw/datasette/pull/725#issuecomment-619489720 https://api.github.com/repos/simonw/datasette/issues/725 MDEyOklzc3VlQ29tbWVudDYxOTQ4OTcyMA== stonebig 4312421 2020-04-26T06:09:59Z 2020-04-26T06:10:13Z NONE

as a complementary remark: the versioning of datasette dependancies will become a problem when the new pip "dependancy resolver" will be activated. for now, it's just warnings via pip checks, later it will be a "no":

datasette 0.40 has requirement aiofiles~=0.4.0, but you have aiofiles 0.5.0.
datasette 0.40 has requirement Jinja2~=2.10.3, but you have jinja2 2.11.2.
{
    "total_count": 0,
    "+1": 0,
    "-1": 0,
    "laugh": 0,
    "hooray": 0,
    "confused": 0,
    "heart": 0,
    "rocket": 0,
    "eyes": 0
}
Update aiofiles requirement from ~=0.4.0 to >=0.4,<0.6 598891570
609393513 https://github.com/simonw/datasette/pull/627#issuecomment-609393513 https://api.github.com/repos/simonw/datasette/issues/627 MDEyOklzc3VlQ29tbWVudDYwOTM5MzUxMw== stonebig 4312421 2020-04-05T10:23:57Z 2020-04-05T10:23:57Z NONE

is there any specific reason to stick to Jinja2~=2.10.3 when there is Jinja-2.11.1 ?

{
    "total_count": 0,
    "+1": 0,
    "-1": 0,
    "laugh": 0,
    "hooray": 0,
    "confused": 0,
    "heart": 0,
    "rocket": 0,
    "eyes": 0
}
Support Python 3.8, stop supporting Python 3.5 521323012
541499978 https://github.com/simonw/datasette/pull/595#issuecomment-541499978 https://api.github.com/repos/simonw/datasette/issues/595 MDEyOklzc3VlQ29tbWVudDU0MTQ5OTk3OA== stonebig 4312421 2019-10-14T04:32:33Z 2019-10-14T04:33:26Z NONE

Maybe make the setup rule conditional, so that below python-3.6, it looks for unicorn-0.8 ?

{
    "total_count": 0,
    "+1": 0,
    "-1": 0,
    "laugh": 0,
    "hooray": 0,
    "confused": 0,
    "heart": 0,
    "rocket": 0,
    "eyes": 0
}
bump uvicorn to 0.9.0 to be Python-3.8 friendly 506300941
541390656 https://github.com/simonw/datasette/issues/593#issuecomment-541390656 https://api.github.com/repos/simonw/datasette/issues/593 MDEyOklzc3VlQ29tbWVudDU0MTM5MDY1Ng== stonebig 4312421 2019-10-13T06:22:07Z 2019-10-13T06:22:07Z NONE

well, I succeeded to make uvicorn work.

{
    "total_count": 0,
    "+1": 0,
    "-1": 0,
    "laugh": 0,
    "hooray": 0,
    "confused": 0,
    "heart": 0,
    "rocket": 0,
    "eyes": 0
}
make uvicorn optional dependancy (because not ok on windows python yet) 506183241
541324637 https://github.com/simonw/datasette/issues/593#issuecomment-541324637 https://api.github.com/repos/simonw/datasette/issues/593 MDEyOklzc3VlQ29tbWVudDU0MTMyNDYzNw== stonebig 4312421 2019-10-12T13:22:50Z 2019-10-12T13:22:50Z NONE

maybe situation is to change ? I see this in uvicorn https://github.com/encode/uvicorn/pull/423

{
    "total_count": 0,
    "+1": 0,
    "-1": 0,
    "laugh": 0,
    "hooray": 0,
    "confused": 0,
    "heart": 0,
    "rocket": 0,
    "eyes": 0
}
make uvicorn optional dependancy (because not ok on windows python yet) 506183241
541323265 https://github.com/simonw/datasette/issues/593#issuecomment-541323265 https://api.github.com/repos/simonw/datasette/issues/593 MDEyOklzc3VlQ29tbWVudDU0MTMyMzI2NQ== stonebig 4312421 2019-10-12T13:04:54Z 2019-10-12T13:07:01Z NONE

hum, well, I fail also with hypercorn on "add_signal_handler()" not implemented directly in Windows, python-3.8 included

https://stackoverflow.com/questions/45987985/asyncio-loops-add-signal-handler-in-windows

{
    "total_count": 0,
    "+1": 0,
    "-1": 0,
    "laugh": 0,
    "hooray": 0,
    "confused": 0,
    "heart": 0,
    "rocket": 0,
    "eyes": 0
}
make uvicorn optional dependancy (because not ok on windows python yet) 506183241

Advanced export

JSON shape: default, array, newline-delimited, object

CSV options:

CREATE TABLE [issue_comments] (
   [html_url] TEXT,
   [issue_url] TEXT,
   [id] INTEGER PRIMARY KEY,
   [node_id] TEXT,
   [user] INTEGER REFERENCES [users]([id]),
   [created_at] TEXT,
   [updated_at] TEXT,
   [author_association] TEXT,
   [body] TEXT,
   [reactions] TEXT,
   [issue] INTEGER REFERENCES [issues]([id])
);
CREATE INDEX [idx_issue_comments_issue]
                ON [issue_comments] ([issue]);
CREATE INDEX [idx_issue_comments_user]
                ON [issue_comments] ([user]);
Powered by Datasette · Query took 28.148ms · About: github-to-sqlite